[Rubygems-developers] [ rubygems-Feature Requests-27269 ] Add required_ruby_implementation to the GemSpec

noreply at rubyforge.org noreply at rubyforge.org
Fri Oct 9 17:08:22 EDT 2009


Feature Requests item #27269, was opened at 2009-10-09 14:08
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=578&aid=27269&group_id=126

Category: other
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Conrad Taylor (conradwt)
Assigned to: Nobody (None)
Summary: Add required_ruby_implementation to the GemSpec

Initial Comment:
In order to fully exploit a particular Ruby implementation, it will be necessary to allow gem developers the ability to create gems targeted to a specific implementations.  For example, this can be any of the following:

ruby
macruby
rubinius
maglev
jruby
and so on

Thus, I would like to propose the adding of an additional attribute to the gem specification (i.e. GemSpec)
called required_ruby_implementation.  This attribute can have the 'any' value by default which specifies all Ruby implementations.  Otherwise, Ruby Gem developers can tag a gem to use a specific ruby implementation when necessary.  Next, this attribute will compliment the attribute, required_ruby_version.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=578&aid=27269&group_id=126


More information about the Rubygems-developers mailing list