[Rubygems-developers] [ rubygems-Bugs-27260 ] rubygems 1.3.5 can't install prerelease gems with dependencies

noreply at rubyforge.org noreply at rubyforge.org
Thu Oct 8 21:24:36 EDT 2009


Bugs item #27260, was opened at 2009-10-08 21:24
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27260&group_id=126

Category: `gem install` command
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Aslak Hellesøy (aslak_hellesoy)
Assigned to: Nobody (None)
Summary: rubygems 1.3.5 can't install prerelease gems with dependencies

Initial Comment:
To reproduce:

# Make sure a dependency isn't on your system. Ignore uninstall error if you don't have it.
sudo gem uninstall term-ansicolor

# cucumber depends on term-ansicolor
sudo gem install cucumber --version 0.4.0.rc1

ERROR:  Error installing cucumber:
	cucumber requires term-ansicolor (>= 1.0.3, runtime)


# It works fine with:
sudo gem install cucumber --version 0.3.104


The error also happens if you run:
sudo gem install cucumber --prerelease

(I'm planning to release cucumber 0.4.0 in a few days, so this might not let you reproduce it with --prerelease).

FYI: cucumber 0.4.0.rc1 was packaged with rubygems 1.3.5

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27260&group_id=126


More information about the Rubygems-developers mailing list