[Rubygems-developers] [ rubygems-Patches-27480 ] CPIO support for RubyGems

noreply at rubyforge.org noreply at rubyforge.org
Mon Nov 23 15:24:16 EST 2009


Patches item #27480, was opened at 2009-11-23 14:24
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=577&aid=27480&group_id=126

Category: other
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Gabriel Gironda (gabrielg)
Assigned to: Nobody (None)
Summary: CPIO support for RubyGems

Initial Comment:
Hi,

I won't delve into the background too much, but basically, I'm frequently hitting the file name size limit RubyGems currently has as it uses tar for archiving (I'm building gems for JavaGems.org). I've built a pure-Ruby cpio implementation, as cpio has a much larger limit on file names than tar does.

I've patched RubyGems to allow for specifying '--use-cpio' when building a gem, and I've added the related tests/support for installing gems that use cpio as the internal archive format. All existing gems still work. Sorry for the format of the patch, it's output from git as I used git-svn to import the existing repository.

Thanks!

- gabe

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=577&aid=27480&group_id=126


More information about the Rubygems-developers mailing list