[Rubygems-developers] [ rubygems-Bugs-27455 ] updated rubygems is not updated

noreply at rubyforge.org noreply at rubyforge.org
Thu Nov 19 05:16:06 EST 2009


Bugs item #27455, was opened at 2009-11-19 00:36
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27455&group_id=126

Category: `gem install` command
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Greg Hazel (ghazel)
Assigned to: Nobody (None)
Summary: updated rubygems is not updated

Initial Comment:
C:\Ruby\lib\ruby\site_ruby\1.8>gem -v
1.3.5

C:\Ruby\lib\ruby\site_ruby\1.8>grep -r -i "gemsver.*1\.3" *
rubygems/rubygems_version.rb:  RubyGemsVersion = '1.3.1'
rubygems.rb:  RubyGemsVersion = VERSION = '1.3.5'


I discovered this problem because:

C:\Ruby\lib\ruby\site_ruby\1.8>gem install eventmachine --source http://gemcutter.org
ERROR:  could not find gem eventmachine locally or in a repository

But:

C:\Ruby\lib\ruby\site_ruby\1.8>gem search eventmachine -r --source http://gemcutter.org

*** REMOTE GEMS ***

eventmachine (0.12.10, 0.12.0)
eventmachine-win32 (0.7.2)
eventmachine_httpserver (0.2.0)
eventmachine_snmpagent (0.0.1)
smparkes-eventmachine (0.12.10.2)


----------------------------------------------------------------------

>Comment By: Luis Lavena (luislavena)
Date: 2009-11-19 07:16

Message:
Hello,

The obsolete version file is no longer used, so what you're reporting is not accurate and has nothing to do with the issue you're facing.

Please include the following when reporting a bug to RubyGems:

* output of gem env
* full output of the gem command you're using but include "--debug -V" options to trigger debug information

Thank you.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27455&group_id=126


More information about the Rubygems-developers mailing list