[Rubygems-developers] [ rubygems-Bugs-26046 ] doesn't allow to differentiate between 1.8 and 1.9 binaries

noreply at rubyforge.org noreply at rubyforge.org
Wed May 27 14:22:12 EDT 2009


Bugs item #26046, was opened at 2009-05-27 18:13
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=26046&group_id=126

Category: #gem and #require methods
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Roger Pack (rogerdpack)
Assigned to: Nobody (None)
Summary: doesn't allow to differentiate between 1.8 and 1.9 binaries

Initial Comment:
currently it appears that currently we "can't build one gem targeting 1.8 and one gem targeting 1.9, and have rubygems differentiate the two"

http://tenderlovemaking.com/2009/05/07/fat-binary-gems-make-the-rockin-world-go-round/

Thanks!
-=r

----------------------------------------------------------------------

>Comment By: Roger Pack (rogerdpack)
Date: 2009-05-27 18:22

Message:
glad to know works been done toward it.
-=r

----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2009-05-27 18:20

Message:
This has been discussed here:

http://rubyforge.org/pipermail/rubygems-developers/2009-April/004522.html

One suggestion is make smarter servers, but there is a RubyForge and RubyGems limitation, not only RubyGems.

HTH,
--
Luis Lavena



----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=26046&group_id=126


More information about the Rubygems-developers mailing list