[Rubygems-developers] [ rubygems-Bugs-26000 ] Type in requirements documentation

noreply at rubyforge.org noreply at rubyforge.org
Sat May 23 11:44:21 EDT 2009


Bugs item #26000, was opened at 2009-05-23 10:44
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=26000&group_id=126

Category: documentation
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Mike Gunderloy (mikeg1)
Assigned to: Nobody (None)
Summary: Type in requirements documentation

Initial Comment:
RDoc for 1.3.3 for Gem::Requirement#parse says "The requirement can be a String or a Gem::Version. A String can be an operator (<, <=, =, =>, >, !=, ~>), a version number, or both, operator first."

That should actually read "The requirement can be a String or a Gem::Version. A String can be an operator (<, <=, =, >=, >, !=, ~>), a version number, or both, operator first."

Note transposition of characters - we love hashrockets in Ruby, but not as comparison operators. I could submit a patch for this, but that seems more trouble than it's worth.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=26000&group_id=126


More information about the Rubygems-developers mailing list