[Rubygems-developers] [ rubygems-Bugs-25759 ] Prelease versions don't satisfy ~> with the intended release number

noreply at rubyforge.org noreply at rubyforge.org
Sat May 2 12:57:16 EDT 2009


Bugs item #25759, was opened at 2009-05-02 11:57
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=25759&group_id=126

Category: #gem and #require methods
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Yossef Mendelssohn (ymendel)
Assigned to: Nobody (None)
Summary: Prelease versions don't satisfy ~> with the intended release number

Initial Comment:
Right now, 2.0.pre is ~> 1.0 instead of ~> 2.0. No good.

It seems the correct way to check a prerelease version against ~> is to use the intended release number (i.e. 2.0 for 2.0.pre).

Patch (output from git show) available at http://gist.github.com/105621

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=25759&group_id=126


More information about the Rubygems-developers mailing list