[Rubygems-developers] Gem::SourceIndex#search deprecation?

Daniel Berger djberg96 at gmail.com
Sat Mar 21 12:29:38 EDT 2009


Hi,

I installed the latest from svn, and ran a "gem clean ptools". I got 
this warning:

/usr/local/lib/ruby/site_ruby/1.8/rubygems/commands/cleanup_command.rb:45:Warning: 
Gem::SourceIndex#search support for Regexp patterns is deprecated

Why is regex search deprecated?

Regards,

Dan


More information about the Rubygems-developers mailing list