[Rubygems-developers] 1.3.2?

Chad Woolley thewoolleyman at gmail.com
Fri Mar 13 15:54:10 EDT 2009


On Thu, Mar 12, 2009 at 4:20 AM, Daniel Berger <djberg96 at gmail.com> wrote:
> Is there anything in limbo that needs fixing first besides --destdir?

What is the status of autoinstalling to ~/.gem if there is no root
permission?  Eric said this might be removed because it cannot be
supported under Ruby 1.9.

If we are going to keep it, we should fix "uninstall" to look here as
well - currently, if a gem gets autoinstalled in ~/.gem, there's no
way to uninstall it without manually specifying GEM_HOME, e.g.:
GEM_HOME=~/.gem/ruby/1.8 gem uninstall json

-- Chad


More information about the Rubygems-developers mailing list