[Rubygems-developers] [Fwd: Re: Question about gems, platform and win32-api]

Daniel Berger djberg96 at gmail.com
Mon Mar 2 00:05:04 EST 2009


Ryan Davis wrote:
> 
> On Feb 26, 2009, at 11:14 , Daniel Berger wrote:
> 
>> Forwarding from Charley. Looks like there's some sort of gems/hoe 
>> interaction bug happening.
> 
> I'd try to help, but you windoze bastards top-post everything to the 
> point of unreadability.

Synopsis: I had two binary gems for win32-api. One for mswin32_60 and 
one for mswin32_80. The '60' gem is the one compatible with the 
one-click installer. However, if another gem generated by Hoe was added 
as a dependency first, it would grab the wrong windows binary gem.

In Charley's example, he had this:

Gem::Specification.new do |s|
    ...
    s.add_dependency('user_choices')
    s.add_dependency('win32-process')
end

But, if you reversed the dependencies, it would work.

I haven't verified this myself, I'm just passing along what I was told.

Regards,

Dan



More information about the Rubygems-developers mailing list