[Rubygems-developers] 1.3.5 soon

Eric Hodel drbrain at segment7.net
Thu Jun 25 17:40:29 EDT 2009


On Jun 24, 2009, at 17:41, Luis Lavena wrote:
> On Wed, Jun 24, 2009 at 9:27 PM, Eric Hodel<drbrain at segment7.net>  
> wrote:
>> On Jun 24, 2009, at 16:28, Luis Lavena wrote:
>>>
>>> On Tue, Jun 23, 2009 at 8:45 PM, Eric Hodel<drbrain at segment7.net>  
>>> wrote:
>>>>
>>>> I've made a 1_3 branch from the REL_1_3_4 tag and merged over the
>>>> prerelease
>>>> gems fixes from it.  I'd like to do a 1.3.5 soon.
>>>>
>>>> Bug fixes:
>>>>
>>>> * Fix use of prerelease gems.
>>>
>>> What about trunk? right now trunk just generate errors:
>>>
>>> ./lib/rubygems/config_file.rb:38:in `initialize': wrong number of
>>> arguments (5 for 4) (ArgumentError)
>>
>> I guess :stdcall is only for 1.9+
>>
>
> Afaik is only for 1.9 only.

Ok, I fixed this on trunk and merged to the branch.

You can try either updating from the branch or downloading a new  
tarball from:

http://segment7.net/temp/rubygems-1.3.4.tgz

> The funniest thing is that Win32API was used to report a deprecation
> warning on p0, but seems now is gone?
>
>>> as for 1_3 branch, we started pretty good:
>>>
>>> Started
>>>
>>> C:/Users/Luis/.gem/ruby/1.8/gems/minitest-1.4.1/lib/minitest/ 
>>> unit.rb:440:in
>>> `trap': unsupported signal SIGINFO (ArgumentError)
>>
>> Does minitest 1.4.0 work?  I will fix minitest tomorrow.
>
> Yup, it worked.

Ryan released minitest 1.4.2 which doesn't trap SIGINFO on systems  
that don't support it.


More information about the Rubygems-developers mailing list