[Rubygems-developers] Trunk version of rubygems should always be > released version

Eric Hodel drbrain at segment7.net
Tue Jun 23 16:53:58 EDT 2009


On Jun 23, 2009, at 12:57, Chad Woolley wrote:
> On Tue, Jun 23, 2009 at 5:32 AM, Hugh Sasse<hgs at dmu.ac.uk> wrote:
>> Sorry if that came across as criticism, I was trying to provide the
>> only help I could at the time.  I'll leave the other points to Eric.
>
> Yeah sorry too for being inflammatory and wasting group bandwidth
> harping on a minor issue.  However, I try to contribute to RubyGems by
> using the API and doing automated functional testing.  This is AFAIK a
> trivial innocuous change that makes it much easier for me to do that,
> and I'd just like an objective response or counterpoint other than
> "no".

I think multiruby does something similar to what you do with gem  
versions, but multiruby doesn't use the ruby version as the  
discriminator, it uses the directory name instead.  In this way  
multiruby allows for multiple installs of the same version (i.e.  
different compile flags) without having to change the version around.


More information about the Rubygems-developers mailing list