[Rubygems-developers] Fixed CI build

Chad Woolley thewoolleyman at gmail.com
Sat Jun 20 05:11:05 EDT 2009

On Fri, Jun 19, 2009 at 3:27 PM, Eric Hodel<drbrain at segment7.net> wrote:
> I reverted this in favor of rake check_extra_deps.

Thanks, didn't know about that.

However, the original build error was because of an outdated version
of hoe which didn't have a 'plugin' method.  The
'install_development_dependencies.rb' approach I had ensures that hoe
> 2.0 is installed (and caused the CI server to update hoe and fix
itself without manual intervention)...

check_extra_deps wouldn't have fixed that, right?

More information about the Rubygems-developers mailing list