[Rubygems-developers] Fixed CI build

Chad Woolley thewoolleyman at gmail.com
Sun Jun 14 22:34:30 EDT 2009

RubyGems has a Continuous Integration build [1].  A commit on Friday
broke it [2], which I triaged with a suggested fix [3] even though I
didn't break it.  It is good to fix builds as soon as they break [4],
especially if your commit broke it.  It was still broken after three
days [5], so I fixed it.

As a nice side benefit, RubyGems now also has an
'install_build_dependencies.rb', just in case people trying to hack on
rubygems are unaware that "undefined method `plugin' for Hoe:Class"
really means "install latest hoe and hoe-seattlerb gems"...

-- Chad

[1] http://ci.pivotallabs.com:3333/builds/RubyGems
[2] http://rubyforge.org/pipermail/rubygems-developers/2009-June/004712.html
[3] http://rubyforge.org/pipermail/rubygems-developers/2009-June/004713.html
[4] http://www.pragprog.com/the-pragmatic-programmer/extracts/software-entropy
[5] http://www.box.net/shared/ebaco1347v

More information about the Rubygems-developers mailing list