[Rubygems-developers] [ rubygems-Bugs-26069 ] Error uninstalling pre-release gem

noreply at rubyforge.org noreply at rubyforge.org
Wed Jun 10 13:14:44 EDT 2009


Bugs item #26069, was opened at 2009-05-30 16:49
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=26069&group_id=126

Category: `gem` commands (other)
Group: v1.3.x
Status: Closed
Resolution: Accepted
Priority: 3
Submitted By: David Chelimsky (dchelimsky)
Assigned to: Phil Hagelberg (technomancy)
Summary: Error uninstalling pre-release gem

Initial Comment:
$ gem list rspec

*** LOCAL GEMS ***

rspec (1.2.7.a)
$ sudo gem uninstall rspec
Remove executables:
	autospec, spec

in addition to the gem? [Yn]  y
Removing autospec
Removing spec
ERROR:  While executing gem ... (NoMethodError)
    undefined method `name' for nil:NilClass
$ gem list rspec

*** LOCAL GEMS ***

rspec (1.2.7.a)


----------------------------------------------------------------------

>Comment By: David Chelimsky (dchelimsky)
Date: 2009-06-10 17:14

Message:
Thanks Phil!

----------------------------------------------------------------------

Comment By: Phil Hagelberg (technomancy)
Date: 2009-06-10 16:35

Message:
Just fixed this last night. r2229 and up should be good.

----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2009-05-30 16:53

Message:
$ gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.4
  - RUBY VERSION: 1.8.6 (2008-03-03 patchlevel 114) [universal-darwin9.0]
  - INSTALLATION DIRECTORY: /Library/Ruby/Gems/1.8
  - RUBY EXECUTABLE: 
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
  - EXECUTABLE DIRECTORY: /usr/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - universal-darwin-9
  - GEM PATHS:
     - /Library/Ruby/Gems/1.8
     - /Users/david/.gem/ruby/1.8
     - 
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ge
ms/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - :sources => ["http://gems.rubyforge.org/", "http://gems.github.com/"]
     - "gem" => "--no-ri --no-rdoc"
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/
     - http://gems.github.com/


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=26069&group_id=126


More information about the Rubygems-developers mailing list