[Rubygems-developers] [ rubygems-Bugs-26801 ] "gem update --system" breaks rubygems under Windows XP using "mingw32-ruby-1.9.1-wxruby-2.0.0-setup.exe"

noreply at rubyforge.org noreply at rubyforge.org
Thu Jul 30 10:27:37 EDT 2009


Bugs item #26801, was opened at 2009-07-30 16:27
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=26801&group_id=126

Category: `gem` commands (other)
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Rainer Wolf (rainer42)
Assigned to: Nobody (None)
Summary: "gem update --system" breaks rubygems under Windows XP using "mingw32-ruby-1.9.1-wxruby-2.0.0-setup.exe"

Initial Comment:
I have a Ruby installation with wxRuby on Windows XP using this installer:

  mingw32-ruby-1.9.1-wxruby-2.0.0-setup.exe 

I typed 

 gem -v 

and found out that I was rubygems 1.3.1. So I typed: 

 gem update --system 

This was the result: 

---begin--- 
Updating RubyGems 
Updating rubygems-update 
Successfully installed rubygems-update-1.3.5 
:0:Warning: Gem::SourceIndex#search support for String patterns is 
deprecated 
Updating RubyGems to 1.3.5 
Installing RubyGems 1.3.5 
c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/ 
config_file. 
rb:39:in `new': wrong number of arguments (5 for 4) (ArgumentError) 
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/ 
lib/rubygems 
/config_file.rb:39:in `<class:ConfigFile>' 
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/ 
lib/rubygems 
/config_file.rb:12:in `<top (required)>' 
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/ 
lib/rubygems 
/gem_runner.rb:8:in `require' 
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/ 
lib/rubygems 
/gem_runner.rb:8:in `<top (required)>' 
        from setup.rb:25:in `require' 
        from setup.rb:25:in `<main>' 
RubyGems system software updated 
--end-- 

Now, when I type 

  gem -v 

I get this: 

---begin--- 
c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/ 
config_file. 
rb:39:in `new': wrong number of arguments (5 for 4) (ArgumentError) 
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/ 
lib/rubygems 
/config_file.rb:39:in `<class:ConfigFile>' 
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/ 
lib/rubygems 
/config_file.rb:12:in `<top (required)>' 
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/ 
lib/rubygems 
/gem_runner.rb:8:in `require' 
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/ 
lib/rubygems 
/gem_runner.rb:8:in `<top (required)>' 
        from c:/ruby/bin/gem.bat:17:in `require' 
        from c:/ruby/bin/gem.bat:17:in `<main>' 
---end--- 

Does this mean I have broken rubygems on mingw32 by typing "gem update 
--system"? Typing 

  "gem search wxruby-ruby19 --remote" 

or trying to install a gem - any gem - gives me the same argument 
error.

Since rubygems was unusable, I uninstalled and reinstalled Ruby, using rubygems 1.3.1 for the time being. So this bug is not "lethal".

Kind regards,

Rainer

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=26801&group_id=126


More information about the Rubygems-developers mailing list