[Rubygems-developers] Please do not reject valid bugs

Chad Woolley thewoolleyman at gmail.com
Sat Jul 25 18:11:27 EDT 2009

On Fri, Jul 24, 2009 at 2:08 PM, Luis Lavena <luislavena at gmail.com> wrote:

> On Fri, Jul 24, 2009 at 5:58 PM, Eric Hodel<drbrain at segment7.net> wrote:
> > It's not a valid bug.  RubyGems required this file as an implementation
> > detail. If you're requiring this file you're doing it wrong.

To be clear, I had already fixed my code.  This was merely reporting a bug
in the rubygems update --system command.  Yes, I was doing it wrong (lazily
putting the require in app rather than test code), and I originally
identified an incorrect solution (putting the file back), but this
*discussion* has resulted in a correct low-priority ticket, assigned to me,
to track the specific issue (a bug is a bug):


For the record, even old setup.rb left files as left overs when
> installed using ruby setup.rb install
> Removal of old scripts like gem_server required manual patching of the
> setup.rb file.

OK.  Now I understand.  Fixable, but low-priority.

-- Chad

More information about the Rubygems-developers mailing list