[Rubygems-developers] --format-executable should be the default

Eric Hodel drbrain at segment7.net
Fri Jul 24 16:58:16 EDT 2009


On Jul 23, 2009, at 03:15, Chad Woolley wrote:

> On Wed, Jul 22, 2009 at 2:52 PM, Eric Hodel <drbrain at segment7.net>  
> wrote:
>
>> I would like to make --format-executable the default for 1.4+.  It  
>> seems
>> many more people are running multiple versions of ruby these days.
>>
>
> I've committed this to trunk in rev 2278.  Didn't write any new  
> tests, but I
> tried it out and it worked for me.  Please test and report any  
> problems.

Please revert this change.  There wasn't even 24 hours of discussion  
on this before you made it.

When the feature was introduced there was a fairly lengthy discussion  
with the JRuby folks.  I doubt they've even had a change to check this  
list.

While this is a low-traffic list, not everybody can read it every  
minute of the day.  I'd rather wait a week to ensure that any  
objections can be met, especially when the default change affects  
multiple ruby implementations.


More information about the Rubygems-developers mailing list