[Rubygems-developers] RubyGems test failures related to multiple interpreters and executable prefix/suffix

Chad Woolley thewoolleyman at gmail.com
Mon Jul 20 22:16:07 EDT 2009


I'm trying to debug a RubyGems test failure on a system which has
multiple ruby interpreter installs and 'ruby' symlinked to
'ruby1.8.6'.

Here is the test failure [1]:

1) Error:
test_execute_prerelease(TestGemCommandsUninstallCommand):
Gem::Installer::ExtensionBuildError:
ERROR: Failed to build gem native extension.

/usr/local/lib/ruby1.8.6/bin/ruby1.8.6 mkrf_conf.rb

rake1.8.6 RUBYARCHDIR=/tmp/test_rubygems_17720/gemhome/gems/pre-2.b/lib
RUBYLIBDIR=/tmp/test_rubygems_17720/gemhome/gems/pre-2.b/lib
sh: rake1.8.6: command not found


Questions:

* What is supposed to get a suffix?  All gem executables from
installed gems, or just 'official' ruby executables such as ri, irb,
etc?

* If the former is true, then there are bugs, because when I install
gems via 'ruby1.8.6', the executables do not have suffixes.

* If the latter is true, what category is Rake in?  Is it just a
normal gem?  If so, it should never be used with an extension, but it
is, which causes this test failure above 'rake1.8.6' not found
(because the actual executable is just 'rake').

Thanks,
-- Chad

[1] http://ci.thewoolleyweb.com/builds/RubyGems/265468d.3


More information about the Rubygems-developers mailing list