[Rubygems-developers] [ rubygems-Bugs-26540 ] 1.3.4 with ruby1.9 on Ubuntu 8.04 AMD64 fails

noreply at rubyforge.org noreply at rubyforge.org
Tue Jul 7 00:11:33 EDT 2009


Bugs item #26540, was opened at 2009-07-07 01:08
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=26540&group_id=126

Category: RubyGems installer (setup.rb)
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Nathan Zook (anoldhacker)
Assigned to: Nobody (None)
Summary: 1.3.4 with ruby1.9 on Ubuntu 8.04 AMD64 fails

Initial Comment:
:~/work/rubygems-1.3.4# ruby1.9 setup.rb 
Installing RubyGems
Installing gem executable
Removing old source_cache files
Removing old RubyGems RDoc and ri
Installing rubygems-1.3.4 ri into /usr/lib/ruby1.9/gems/1.9.0/doc/rubygems-1.3.4/ri
ERROR:  While executing gem ... (ArgumentError)
    invalid mbstring sequence

# This is from the Universe repository
~/work/rubygems-1.3.4# ruby --version
ruby 1.9.0 (2007-12-25 revision 14709) [x86_64-linux]

~/work/rubygems-1.3.4# ruby1.9 -v setup.rb >output 2>&1

# output.gz attached

----------------------------------------------------------------------

>Comment By: Luis Lavena (luislavena)
Date: 2009-07-07 01:11

Message:
I would say that you're trying to install an old, unstable version of Ruby 1.9 (1.9.0)

The stable and recommended version for 1.9 line is 1.9.1-p129.

I would recommend installing 1.9.1 at least, but leave this open for other to suggest better solutions.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=26540&group_id=126


More information about the Rubygems-developers mailing list