[Rubygems-developers] [ rubygems-Bugs-24770 ] RubyGems 1.3.1 doesn't install on MS VISTA Business

noreply at rubyforge.org noreply at rubyforge.org
Sun Jul 5 13:11:52 EDT 2009


Bugs item #24770, was opened at 2009-03-22 21:11
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=24770&group_id=126

Category: RubyGems installer (setup.rb)
Group: None
>Status: Closed
>Resolution: Out of Date
Priority: 3
Submitted By: Luis V. Chavez (louiss)
Assigned to: Luis Lavena (luislavena)
Summary: RubyGems 1.3.1 doesn't install on MS VISTA Business

Initial Comment:
Hello
i want to report a big problem when i trying to install the rubygems from 1.2.0 to 1.3.1 
always when i install it and after when i want check it i get an error messages and not the normaly like gem -v
1.2.0
or 
1.3.1

i think this is a big problem because i reinstall my machine today and has update the windows and i have a frish installation of ruby and now i see this error.
unfortunately i can use rubyonrails on windows because rails need rubygems 1.3.1
to run the webapplications...


i hope you bring or fix the zip file from the webseite. thanksss.

----------------------------------------------------------------------

>Comment By: Luis Lavena (luislavena)
Date: 2009-07-05 14:11

Message:
Closing this due lack of feedback and error message.

I believe this is related to Zlib issues associated with garbagecollect binaries of Ruby.

----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2009-03-27 19:33

Message:
One-Click Installer has been in RC2 since 2 months.

That version has been quite stable without any major issue.

I think is time to upload a final 186-27.

In the Vista front, further details about the error are needed.


----------------------------------------------------------------------

Comment By: Luis V. Chavez (louiss)
Date: 2009-03-26 17:59

Message:
yes
in Vista i click always the option run as admin
when i want to start the ms-terminal and want to update the
rubygems

i will uninstall the ruby version and i want to try again to
install it with the actually rubygems..

----------------------------------------------------------------------

Comment By: Jirapong Nanta (jirapong)
Date: 2009-03-26 16:16

Message:
Did you try to run command-line with as admin?

----------------------------------------------------------------------

Comment By: Luis V. Chavez (louiss)
Date: 2009-03-23 05:14

Message:
additionally ..
i have tried to install it manually too..
this means i downloaded it and unpacked it and tried to
install it in the ms-terminal with root rights with ruby
setup.rb but it didnt help

----------------------------------------------------------------------

Comment By: Luis V. Chavez (louiss)
Date: 2009-03-23 05:12

Message:
hello
the problem occurs when i have installed  Ruby Version
1.8.6-26 Final Release	   2007-12-14 23:13
and try to update this version. i could update to the
rubygem version 1.2.0

but i found a currently solution for this error.
i installed the last ruby version for windows, unfortunately
it is a Release Candidate Version, 1.8.6-27 Release Candidate 2
and the problem is solved.

i dont know if i should use this Release.

----------------------------------------------------------------------

Comment By: Daniel Berger (djberg96)
Date: 2009-03-23 01:08

Message:
Was this caused by "gem update system"? Can you show us the error you received?

You can also try downloading rubygems and running "ruby setup.rb" manually. Does that work?

Regards,

Dan

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=24770&group_id=126


More information about the Rubygems-developers mailing list