[Rubygems-developers] How to rebuild a gem

Luis Lavena luislavena at gmail.com
Fri Jan 23 09:02:16 EST 2009


On Fri, Jan 23, 2009 at 6:45 AM, Han Holl <han.holl at tietoenator.com> wrote:
> On Thursday 22 January 2009, Luis Lavena wrote:
>
>> You can generate it:
>>
>> gem spec pg > specifications/pg-0.7.9.2008.10.13.gemspec
>>
>> That's your last step to have the gem installed, I believe.
>>
> Thanks Luis, that was what I was looking for.
> Unfortunately, it doesn't work.
> I tried in several directories, but each time got:
>
> ERROR:  Unknown gem 'pg'
>
> It seems there is still something missing.
>

Oh yeha, my fault:

gem spec pg --version '0.7.9.2008.10.13' --remote >
specifications/pg-0.7.9.2008.10.13.gemspec

It was trying to query it locally :-P

> Han Holl
>
> _______________________________________________
> Rubygems-developers mailing list
> Rubygems-developers at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rubygems-developers
>



-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Rubygems-developers mailing list