[Rubygems-developers] How to rebuild a gem

James Tucker jftucker at gmail.com
Mon Jan 19 11:24:20 EST 2009


I built a horrible tool called gem repackager, which works well for  
this on win32. On *nix it often requires root to run, but that depends  
on the permission of your gem tree.

It needs a lot of love, but it worked great for the time when I needed  
it for win32, and should work on *nix systems too.

I'm accepting patches / improvements as they come about, it's really  
had very little time put into it, and is now very old.

Later this month, I should get around to putting it into a git repo,  
giving it some tests, and a new set of rake tasks, and push it as a  
gem to the libraggi project, which is where most of this toy / util  
stuff is gunna live.

http://gem-repackager.rubyforge.org/svn/

Finally, feel free to ping me off the list with any questions you  
have, if you feel it's appropriate.

HTH

On 19 Jan 2009, at 15:47, Han Holl wrote:

>
> Hi,
>
> I want to install a gem, but it doesn't build on my platform.
> I fix the C-source, and submit a patch to the owner.
>
> But I want to go on, and not wait for the maintainer to apply my  
> patch.
> How can I rebuild the gem, and install.
>
> I tried to untar the original gem, untar data.tar.gz, drop in my .c  
> file, and
> tar it up again, but this doesn't work. I get an error message the  
> some
> directory already exists. I rm -rf'ed everything in the gem  
> directory tree
> that belonged to this gem, but still the same error.
>
> Is there a way to do this ?
>
> Cheers,
>
> Han Holl
>
> PS It may be relevant that I try this on a ruby-1.9.1 in /usr/local/ 
> bin, with
> ruby-1.8.6 in /usr/bin.
> _______________________________________________
> Rubygems-developers mailing list
> Rubygems-developers at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rubygems-developers



More information about the Rubygems-developers mailing list