[Rubygems-developers] The deprecation of autorequire

Chad Woolley thewoolleyman at gmail.com
Thu Jan 15 00:17:17 EST 2009


On Wed, Jan 14, 2009 at 10:08 PM, Jim Weirich <jim.weirich at gmail.com> wrote:
> Only use a 'gem' command if you want something other than the latest
> installed version of a gem.  You application should arrange to invoke the
> gem command early in the program, after 'rubygems' has been required, but
> before any other requires have run.

We use GemInstaller's 'autogem' function to accomplish this via
/config/preinitializer.rb in all our Rails apps:

http://geminstaller.rubyforge.org/documentation/tutorials.html#using_the_autogem_option_to_automatically_require_gems

This works very well for us, and I believe Rails' config.gems can do
the same thing (except for Rails itself, would cause the universe to
implode)

-- Chad


More information about the Rubygems-developers mailing list