[Rubygems-developers] can not install RubyGems (uninitialized constant YAML::Syck::DefaultLoader (NameError))

Greg Hauptmann greg.hauptmann.ruby at gmail.com
Sat Feb 7 05:03:57 EST 2009


PS.  I was just having a look where "gem env" fails (refer code below).  It
would seem the 'yaml/syck' require works OK, but it's just the DefaultLoader
class it can't find.  What does this imply re my  ruby installation, which
seems to be ok I think.  How would I verify the "DefaultLoader" class was
present in my Ruby installation?   (i.e. trying to determine if my ruby
installation is missing something, or there is a bug in the rubygems, or
some issue in the rubygems install)


module YAML
    begin
        require 'yaml/syck'
        @@parser = YAML::Syck::Parser
        @@loader = YAML::Syck::DefaultLoader   # <=== THIS IS WHERE IT FALLS
OVER
        @@emitter = YAML::Syck::Emitter


thanks in advance
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rubygems-developers/attachments/20090207/925ffe2f/attachment.html>


More information about the Rubygems-developers mailing list