[Rubygems-developers] can not install RubyGems (uninitialized constant YAML::Syck::DefaultLoader (NameError))

Greg Hauptmann greg.hauptmann.ruby at gmail.com
Sat Feb 7 03:01:37 EST 2009

Hey Luis,

2009/2/7 Luis Lavena <luislavena at gmail.com>

> Besides you having so many ruby references in your setup, what is the
> output of "gem env"?

At the moment this gives the error too:
[root at home ~]# gem env
/usr/lib/ruby/1.8/yaml.rb:14: uninitialized constant
YAML::Syck::DefaultLoader (NameError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in

2009/2/7 Luis Lavena <luislavena at gmail.com>
> sudo apt-get build-dep ruby1.8
> That should install all the required build dependencies to compile
> ruby from source.

I'm get the following after running this, so apt-get doesn't seem to be set

[root at home ~]# sudo apt-get build-dep ruby1.8
Reading Package Lists...
Building Dependency Tree...
E: You must put some 'source' URIs in your sources.list
[root at home ~]#

I'm no RedHat linux, so it is "apt-get" I should be using something else?  I
note "yum" is not installed on my box however.

Also I couldn't see in the Ruby doco where it specifies "build-dep ruby1.8"
as a dependancy for building ruby.  Where did you see this?

Thanks again
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rubygems-developers/attachments/20090207/d17117de/attachment.html>

More information about the Rubygems-developers mailing list