[Rubygems-developers] can not install RubyGems (uninitialized constant YAML::Syck::DefaultLoader (NameError))

Luis Lavena luislavena at gmail.com
Fri Feb 6 18:59:16 EST 2009


On Fri, Feb 6, 2009 at 9:46 PM, Greg Hauptmann
<greg.hauptmann.ruby at gmail.com> wrote:
> PS. Luis - I did do (probably silly for not understanding what I was
> doing) an "apt-get install ruby-libs".  I'm not sure if this is
> significant.  I guess I didn't really remember how Ruby was installed
> on my box and tried to do an update....
>

sudo apt-get build-dep ruby1.8

That should install all the required build dependencies to compile
ruby from source.

HTH,
-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Rubygems-developers mailing list