[Rubygems-developers] [ rubygems-Bugs-27608 ] installation of some dependencies fails

noreply at rubyforge.org noreply at rubyforge.org
Wed Dec 30 15:21:11 EST 2009


Bugs item #27608, was opened at 2009-12-21 11:35
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27608&group_id=126

Category: `gem install` command
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Roger Pack (rogerdpack)
Assigned to: Nobody (None)
Summary: installation of some dependencies fails

Initial Comment:
Originally reported here
http://www.ruby-forum.com/topic/200649#new

"gem install sane" fails with

shot at devielle:~$ gem install google_hash
ERROR:  Error installing google_hash:
  sane requires os (>= 0, runtime)

more info (from different computer).

C:\dev\ruby\downloads\jruby\bin>gem install --debug -V sane

Exception `Gem::LoadError' at C:/dev/ruby/downloads/jruby/lib/ruby/site_ruby/1.8/rubygems.rb:827 - Could not find RubyGem jruby-openssl (>= 0)

JRuby limited openssl loaded. http://jruby.org/openssl
gem install jruby-openssl for full support.
Exception `Gem::LoadError' at C:/dev/ruby/downloads/jruby/lib/ruby/site_ruby/1.8/rubygems.rb:827 - Could not find RubyGem jruby-openssl (>= 0)

Exception `LoadError' at C:/dev/ruby/downloads/jruby/lib/ruby/site_ruby/shared/jruby/openssl/autoloads/x509.rb:8 - OpenSSL::X509 requires the jruby-openssl gem
Exception `Gem::LoadError' at C:/dev/ruby/downloads/jruby/lib/ruby/site_ruby/1.8/rubygems.rb:827 - Could not find RubyGem test-unit (>= 0)

GET 200 OK: http://gems.rubyforge.org/latest_specs.4.8.gz
GET 200 OK: http://gems.github.com/latest_specs.4.8.gz
Installing gem sane-0.16.0
Exception `Gem::InstallError' at C:/dev/ruby/downloads/jruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:255 - sane requires os (>= 0, runtime)
ERROR:  Error installing sane:
        sane requires os (>= 0, runtime)
Exception `Gem::SystemExitException' at C:/dev/ruby/downloads/jruby/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:170 - Exiting RubyGems with exit_code 1


C:\dev\ruby\downloads\jruby\bin>gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.5
  - RUBY VERSION: 1.8.7 (2009-12-21 patchlevel 174) [java]
  - INSTALLATION DIRECTORY: C:/dev/ruby/downloads/jruby/lib/ruby/gems/1.8
  - RUBY EXECUTABLE: C:/dev/ruby/downloads/jruby/bin/jruby.exe
  - EXECUTABLE DIRECTORY: C:/dev/ruby/downloads/jruby/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - universal-java-1.6
  - GEM PATHS:
     - C:/dev/ruby/downloads/jruby/lib/ruby/gems/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - "install" => "--env-shebang"
     - "update" => "--env-shebang"
     - :sources => ["http://gems.rubyforge.org/"]
     - "gem" => "--no-ri --no-rdoc"
     - "gemcutter_key" => "1fac3373c066bf27dd8ad967f1bb7505"
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/

----------------------------------------------------------------------

>Comment By: Luis Lavena (luislavena)
Date: 2009-12-30 17:21

Message:
When you install thin, it compiles eventmachine.

Seems that it only resolves the first dependency and then fails.

Can you please try with the version of RubyGems that cames with 1.9.1 instead of the 1.3.5 on top of it?

Thank you.


----------------------------------------------------------------------

Comment By: Roger Pack (rogerdpack)
Date: 2009-12-30 15:27

Message:
here's another manifestation of it

E:\dev\ruby\allgems\lib>gem install thin
Building native extensions.  This could take a while...
ERROR:  Error installing thin:
        thin requires rack (>= 1.0.0, runtime)

E:\dev\ruby\allgems\lib>gem install rack
Successfully installed rack-1.0.1
1 gem installed

E:\dev\ruby\allgems\lib>gem install thin
Building native extensions.  This could take a while...
Successfully installed thin-1.2.5
1 gem installed

E:\dev\ruby\allgems\lib>ruby -v
ruby 1.9.1p376 (2009-12-07 revision 26041) [i386-mingw32]

E:\dev\ruby\allgems\lib>gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.5
  - RUBY VERSION: 1.9.1 (2009-12-07 patchlevel 376) [i386-
mingw32]
  - INSTALLATION DIRECTORY: 
E:/installs/ruby191p376/lib/ruby/gems/1.9.1
  - RUBY EXECUTABLE: E:/installs/ruby191p376/bin/ruby.exe
  - EXECUTABLE DIRECTORY: E:/installs/ruby191p376/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-mingw32
  - GEM PATHS:
     - E:/installs/ruby191p376/lib/ruby/gems/1.9.1
     - C:/Documents and Settings/packrd/.gem/ruby/1.9.1
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - :sources => ["http://gems.rubyforge.org/"]
     - "gem" => "--no-ri --no-rdoc"
     - "gemcutter_key" => "1fac3373c066bf27dd8ad967f1bb7505"
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27608&group_id=126


More information about the Rubygems-developers mailing list