[Rubygems-developers] [ rubygems-Bugs-27575 ] Gem reports: WARNING: RubyGems 1.2+ index not found for

noreply at rubyforge.org noreply at rubyforge.org
Wed Dec 16 06:12:05 EST 2009


Bugs item #27575, was opened at 2009-12-16 02:29
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27575&group_id=126

Category: other
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Yann Golanski (kierun)
Assigned to: Nobody (None)
Summary: Gem reports: WARNING:  RubyGems 1.2+ index not found for

Initial Comment:
I cannot update, install or do anything with gems because of this message.  Does anyone have any idea?

$ uname -a
Linux desk4 2.6.31-16-generic #52-Ubuntu SMP Thu Dec 3 22:07:16 UTC 2009 x86_64 GNU/Linux
$ gem -v
1.3.5
$ gem env 
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.5
  - RUBY VERSION: 1.8.7 (2009-06-12 patchlevel 174) [x86_64-linux]
  - INSTALLATION DIRECTORY: /var/lib/gems/1.8
  - RUBY EXECUTABLE: /usr/bin/ruby1.8
  - EXECUTABLE DIRECTORY: /var/lib/gems/1.8/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-linux
  - GEM PATHS:
     - /var/lib/gems/1.8
     - /home/yann/.gem/ruby/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - :sources => ["http://gems.rubyforge.org/", "http://gems.github.com"]
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/
     - http://gems.github.com
$ gem install rainbow
WARNING:  RubyGems 1.2+ index not found for:
	http://gems.rubyforge.org/

RubyGems will revert to legacy indexes degrading performance.
Bulk updating Gem source index for: http://gems.rubyforge.org/
ERROR:  While executing gem ... (NoMethodError)
    undefined method `gems' for #<Array:0x7fd59c3dbd40>


----------------------------------------------------------------------

>Comment By: Ryan Davis (zenspider)
Date: 2009-12-16 03:12

Message:
I've got rubygems 1.3.5 running on 1.8.7 as well. I've got gems.rubyforge.org as my only source and I can install rainbow just fine.

So either I'm guessing that you hit the server while their index was missing or being generated or something else is causing the problem. You may want to try removing the github source, but I tested against that and it seems to also work fine.

If you still have the problem, please add --debug and --backtrace and give us the full output.

Thanks.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=27575&group_id=126


More information about the Rubygems-developers mailing list