[Rubygems-developers] Backport of ruby-trunk changes into RubyGems

Luis Lavena luislavena at gmail.com
Tue Dec 8 12:36:18 EST 2009

On Mon, Dec 7, 2009 at 10:52 AM, Daniel Berger <djberg96 at gmail.com> wrote:
> Luis Lavena wrote:
>> Hello Guys,
>> The latest Ruby release (1.9.1-p376) was done today, sunday.
>> That release integrates a series of fixes for RubyGems, but I believe
>> those changes weren't backported to RubyGems repository.
>> Also, AFAIK, those changes will not work with 1.8, and will require some
>> tweaks.
>> I'll like to know what is the plan or the schedule in relation to this.
>> I'm asking for several reasons, one, a newer RubyGems release with
>> some of the fixes will be helpful. Second, updated RubyGems in 1.9
>> allow newer gems to be installed.
>> Third, last but not least, I'm finishing things for final release of
>> RubyInstaller for Windows, and want to ship both 1.8 and 1.9 with
>> stable RubyGems installations.
> Do you have a summary of the changes? I don't follow 1.9.x development.

I can't read ChangeLog GNU formatting, is distracting, but there are
several changes in 1.9.1 and 1.9.2 (trunk) that never merged back and
if so, will fail for 1.8 due missing "encoding" stuff.

Will checkout both and do a folder diff later today.
Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

More information about the Rubygems-developers mailing list