[Rubygems-developers] Can't require 'rubygems/specification' anymore?

Chad Woolley thewoolleyman at gmail.com
Tue Dec 8 11:52:23 EST 2009

On Tue, Dec 8, 2009 at 6:34 AM, Trans <transfire at gmail.com> wrote:
>  require 'rubygems/specification'
>  NameError: uninitialized constant Gem
>      from /usr/local/lib/site_ruby/1.8/rubygems/version.rb:28
>      from /usr/local/lib/site_ruby/1.8/rubygems/specification.rb:7:in
> `require'
>      from /usr/local/lib/site_ruby/1.8/rubygems/specification.rb:7
>      from (irb):1:in `require'
>      from (irb):1

Maybe related to this this general bug (old files not deleted on
upgrade)?  I didn't investigate, just an idea:


More information about the Rubygems-developers mailing list