[Rubygems-developers] Backport of ruby-trunk changes into RubyGems

Luis Lavena luislavena at gmail.com
Mon Dec 7 01:50:06 EST 2009


Hello Guys,

The latest Ruby release (1.9.1-p376) was done today, sunday.

That release integrates a series of fixes for RubyGems, but I believe
those changes weren't backported to RubyGems repository.

Also, AFAIK, those changes will not work with 1.8, and will require some tweaks.

I'll like to know what is the plan or the schedule in relation to this.

I'm asking for several reasons, one, a newer RubyGems release with
some of the fixes will be helpful. Second, updated RubyGems in 1.9
allow newer gems to be installed.

Third, last but not least, I'm finishing things for final release of
RubyInstaller for Windows, and want to ship both 1.8 and 1.9 with
stable RubyGems installations.

Thank you.
-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Rubygems-developers mailing list