[Rubygems-developers] [ rubygems-Bugs-25516 ] gem cleanup still dysfunctional in 1.3.2

noreply at rubyforge.org noreply at rubyforge.org
Sun Apr 19 19:46:24 EDT 2009


Bugs item #25516, was opened at 2009-04-16 19:20
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=25516&group_id=126

Category: `gem` commands (other)
Group: v1.3.x
Status: Open
Resolution: None
Priority: 3
Submitted By: Brett Eisenberg (brett)
Assigned to: Nobody (None)
Summary: gem cleanup still dysfunctional in 1.3.2

Initial Comment:
[ruby at rubygems]:~% gem cleanup
Cleaning up installed gems...
Attempting to uninstall tzinfo-0.3.12
Unable to uninstall tzinfo-0.3.12:
	Gem::InstallError: cannot uninstall, check `gem list -d tzinfo`
[ruby at rubygems]:~% gem list -d tzinfo

*** LOCAL GEMS ***

tzinfo (0.3.13, 0.3.12)
    Author: Philip Ross
    Rubyforge: http://rubyforge.org/projects/tzinfo
    Homepage: http://tzinfo.rubyforge.org/
    Installed at (0.3.13): /Users/ruby/.gem/ruby/1.8
                 (0.3.12): /Users/ruby/.gem/ruby/1.8

    Daylight-savings aware timezone library
[ruby at rubygems]:~% gem uninstall tzinfo -v '= 0.3.12'
Successfully uninstalled tzinfo-0.3.12



----------------------------------------------------------------------

>Comment By: Brett Eisenberg (brett)
Date: 2009-04-19 19:46

Message:
[ruby at rubygems]:~% gem cleanup --debug
Exception `NameError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:161
- uninitialized constant Gem::Commands::CleanupCommand
Cleaning up installed gems...
Attempting to uninstall memcache-client-1.7.1
Exception `Gem::InstallError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/uninstaller.rb:76
- cannot uninstall, check `gem list -d memcache-client`
Unable to uninstall memcache-client-1.7.1:
	Gem::InstallError: cannot uninstall, check `gem list -d
memcache-client`
Attempting to uninstall ruby-openid-2.1.2
Exception `Gem::InstallError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/uninstaller.rb:76
- cannot uninstall, check `gem list -d ruby-openid`
Unable to uninstall ruby-openid-2.1.2:
	Gem::InstallError: cannot uninstall, check `gem list -d
ruby-openid`
Attempting to uninstall rspec-1.2.2
Exception `Gem::InstallError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/uninstaller.rb:76
- cannot uninstall, check `gem list -d rspec`
Unable to uninstall rspec-1.2.2:
	Gem::InstallError: cannot uninstall, check `gem list -d rspec`
Attempting to uninstall fastthread-1.0.6
Exception `Gem::InstallError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/uninstaller.rb:76
- cannot uninstall, check `gem list -d fastthread`
Unable to uninstall fastthread-1.0.6:
	Gem::InstallError: cannot uninstall, check `gem list -d
fastthread`
Attempting to uninstall json-1.1.3
Exception `Gem::InstallError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/uninstaller.rb:76
- cannot uninstall, check `gem list -d json`
Unable to uninstall json-1.1.3:
	Gem::InstallError: cannot uninstall, check `gem list -d json`
Attempting to uninstall cucumber-0.2.3
Exception `Gem::InstallError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/uninstaller.rb:76
- cannot uninstall, check `gem list -d cucumber`
Unable to uninstall cucumber-0.2.3:
	Gem::InstallError: cannot uninstall, check `gem list -d
cucumber`
Attempting to uninstall hoe-1.12.1
Exception `Gem::InstallError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/uninstaller.rb:76
- cannot uninstall, check `gem list -d hoe`
Unable to uninstall hoe-1.12.1:
	Gem::InstallError: cannot uninstall, check `gem list -d hoe`
Attempting to uninstall thoughtbot-factory_girl-1.2.0
Exception `Gem::InstallError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/uninstaller.rb:76
- cannot uninstall, check `gem list -d thoughtbot-factory_girl`
Unable to uninstall thoughtbot-factory_girl-1.2.0:
	Gem::InstallError: cannot uninstall, check `gem list -d
thoughtbot-factory_girl`
Attempting to uninstall rake-compiler-0.4.0
Exception `Gem::InstallError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/uninstaller.rb:76
- cannot uninstall, check `gem list -d rake-compiler`
Unable to uninstall rake-compiler-0.4.0:
	Gem::InstallError: cannot uninstall, check `gem list -d
rake-compiler`
Clean Up Complete


----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2009-04-19 17:46

Message:
Can you try running the exact same command with debug information turned on?

gem cleanup --debug


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=575&aid=25516&group_id=126


More information about the Rubygems-developers mailing list