[Rubygems-developers] rubygems / http://gems.rubyforge.org/ stability (RubyGems will revert to legacy indexes degrading performance)

Greg Hauptmann greg.hauptmann.ruby at gmail.com
Tue Sep 23 17:56:02 EDT 2008


PSS.  another example:

Macintosh-2:myequity greg$ sudo gem install hobo --debug
Password:
Exception `NameError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:134 -
uninitialized constant Gem:
:Commands::InstallCommand
Exception `Timeout::Error' at /opt/local/lib/ruby/1.8/timeout.rb:54 -
execution expired
Exception `Gem::RemoteFetcher::FetchError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/remote_fetcher.rb:142 -
timed out (http://gems.rubyforge.org/latest_specs.4.8.gz)
WARNING:  RubyGems 1.2+ index not found for:


RubyGems will revert to legacy indexes degrading performance.
Exception `Net::HTTPBadResponse' at
/opt/local/lib/ruby/1.8/net/http.rb:2019 - wrong status line:
"\037\213\b\000\236X\331H\000\003t\275[\214dIv\030\246\316\231\235\251G\326\273\252\237\263Kn\213\213\026idoWV\365k\355\001\253\247{\246g\226\323=\303\256\336\035\212\244\234\270y\357\315\314\250\274\257\276qoee\221\366\222\342~P\022\b\254\f\361K\004\f\233\004\204\375\260(\311
\215\005M\203\240a\v
\r\330\220\274\260\rC\024\r\177\b\376\"\026\v\257\r\030\262}\316\211sNDV\317b\246\2733N\304\215\e7\036'\316\373\274\271\364K\235\357\256\377\322\322\315\356\243\347/?x\364\342\3317\276\266\3654\315\277\366\265o\246\2655e\361Ko\335\\\271s\273\177\373\316\315\345\272\035\316\241\341\215GqcN\323'\246N\343\246\254\347\037\224\365\v\250\371\306\277\373\327\\\333\375\333\017\216V\241\335e\327\356E\032\227u\322\373\372\223\367\036\273&Kwn\337\245\006\333\320\300>\262\357\3338\252\322D\237\207\267Q\365UW\375Ad\233\347\251m\322\3448m\202\227\334\345FIR\247\326\276W\226\323\217\362\252\254\233\264v\215V\261\247\375\003ju\375Q\22Exception
`Timeout::Error' at /opt/local/lib/ruby/1.8/timeout.rb:54 - execution
expired
Exception `Gem::RemoteFetcher::FetchError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/remote_fetcher.rb:142 -
timed out (http://gems.rubyforge.org/quick/latest_index.rz)
Updating metadata for 98 gems from http://gems.rubyforge.org/
Exception `TypeError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:488 -
incompatible marshal file format (can't be read)
        format version 4.8 required; 65.78 given
Exception `NoMethodError' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:172 -
undefined method `full_name' for #<String:0x1aef578>
ERROR:  While executing gem ... (NoMethodError)
    undefined method `full_name' for #<String:0x1aef578>
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:172:in
`add_spec'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:523:in
`update_with_missing'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:517:in `each'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:517:in
`update_with_missing'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:355:in
`update'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache_entry.rb:42:in
`refresh'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:249:in
`refresh'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:242:in
`each'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:242:in
`refresh'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:41:in
`cache'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:86:in
`search_with_source'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:72:in `fetch'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:242:in
`warn_legacy'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:69:in `fetch'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:94:in
`find_gems_with_sources'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:187:in
`find_spec_by_name_and_version'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:208:in
`install'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:73:in
`execute'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:70:in
`each'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:70:in
`execute'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/command.rb:136:in `invoke'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:105:in
`process_args'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:75:in
`run'
        /opt/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:39:in `run'
        /opt/local/bin/gem:24
Macintosh-2:myequity greg$


On Tue, Sep 23, 2008 at 10:17 PM, Greg Hauptmann
<greg.hauptmann.ruby at gmail.com> wrote:
> still having problems here - latest example is when I've tried to
> install hobo - any suggestions would be great
>
> -------
> Macintosh-2:gems greg$ sudo gem install hobo --debug
> Exception `NameError' at
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:134 -
> uninitialized constant Gem::Commands::InstallCommand
> Exception `Timeout::Error' at /opt/local/lib/ruby/1.8/timeout.rb:54 -
> execution expired
> Exception `Gem::RemoteFetcher::FetchError' at
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/remote_fetcher.rb:142 -
> timed out (http://gems.rubyforge.org/latest_specs.4.8.gz)
> WARNING:  RubyGems 1.2+ index not found for:
>
>
> RubyGems will revert to legacy indexes degrading performance.
> Exception `Net::HTTPBadResponse' at
> /opt/local/lib/ruby/1.8/net/http.rb:2019 - wrong status line:
> "\037\213\b\000bw\330H\000\003t\275[\214dIv\030\246\316\231\235\251G\326\273\252\237\263K\262\305E\233\024\262\267+\253\372\265\326\200\325\323=\3233\313\351\236aW\357,\265\244\234\270y\357\315\314\250\274\257\276qoee\211\322J\346\032\246L\020X\031\342\227\370c\211\260\260?\262E\2024\0264\r\202\206-\2004`\303\302B\006lQ\004l\200?\006\210\305\332\373aC\262\3179q\316\211\310\352Y\314tw\306\211\270q\343\306\343\304y\2377\227~\251\363\335\365_Z\272\331}\364\374\345\a\217^<\373\372W\267\236\246\371W\277\372YZ[S\026\277\364\326\315\225;\267\373\267\357\334\\\256\333\341\034\032\336x\0247\3464}b\3524n\312z\376AY\277\200\232\257\377\373\177\305\265\335\277\375\340h\025\332]v\355^\244qY'\275\257=y\357\261k\262t\347\366]j\260\r\r\354#\373\276\215\243*M\364yx\eU_u\325\037D\266y\236\332&M\216\323&x\311]n\224$uj\355{e9\375(\257\312\272Ik\327h\025{\332?\240V\327\037%\271)\214m\352\b\373\211\243\321\250\314\3027\356S\263\235GIException
> `Timeout::Error' at /opt/local/lib/ruby/1.8/timeout.rb:54 - execution
> expired
> Exception `Gem::RemoteFetcher::FetchError' at
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/remote_fetcher.rb:142 -
> timed out (http://gems.rubyforge.org/quick/latest_index.rz)
> Updating metadata for 96 gems from http://gems.rubyforge.org/
> Exception `TypeError' at
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:488 -
> incompatible marshal file format (can't be read)
>        format version 4.8 required; 65.78 given
> Exception `NoMethodError' at
> /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:172 -
> undefined method `full_name' for #<String:0x1af3574>
> ERROR:  While executing gem ... (NoMethodError)
>    undefined method `full_name' for #<String:0x1af3574>
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:172:in
> `add_spec'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:523:in
> `update_with_missing'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:517:in `each'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:517:in
> `update_with_missing'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:355:in
> `update'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache_entry.rb:42:in
> `refresh'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:249:in
> `refresh'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:242:in
> `each'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:242:in
> `refresh'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:41:in
> `cache'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:86:in
> `search_with_source'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:72:in `fetch'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:242:in
> `warn_legacy'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:69:in `fetch'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:94:in
> `find_gems_with_sources'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:187:in
> `find_spec_by_name_and_version'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:208:in
> `install'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:73:in
> `execute'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:70:in
> `each'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:70:in
> `execute'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/command.rb:136:in `invoke'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:105:in
> `process_args'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:75:in
> `run'
>        /opt/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:39:in `run'
>        /opt/local/bin/gem:24
> Macintosh-2:gems greg$
>
> ------
>
> On Sat, Sep 13, 2008 at 6:42 AM, Eric Hodel <drbrain at segment7.net> wrote:
>> On Sep 11, 2008, at 20:49 PM, Greg Hauptmann wrote:
>>
>>> Tks Eric,  so does this mean I'm really up for a manual install...can
>>> one do manual gem installs?  do you think I should raise an issue with
>>> my ISP, however I'm not exactly sure how I'd phase the support
>>> request?
>>
>> You could try:
>>
>> gem install -V some_gem
>>
>> It should print out what RubyGems tried to fetch and what response was
>> received, then use something like curl -I URL to see if RubyGems is insane
>> or not.
>> _______________________________________________
>> Rubygems-developers mailing list
>> Rubygems-developers at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/rubygems-developers
>>
>


More information about the Rubygems-developers mailing list