[Rubygems-developers] RubyGems 1.3.0 Upcoming

Trans transfire at gmail.com
Tue Sep 16 08:35:40 EDT 2008



On Aug 17, 7:08 pm, Eric Hodel <drbr... at segment7.net> wrote:
> Please test out RubyGems trunk.  The best way to install it and make  
> sure you can still update to 1.3.0 on the official release is:
>
> $ svn up
> $ sudo rake install
>
> Current Release notes for 1.3.0:
>
> = Announce: RubyGems Release 1.3.0
>
> Release 1.3.0 adds new features and fixes some bugs.
>
> New features:
>
> * RubyGems doesn't print LOCAL/REMOTE titles for `gem query` and  
> friends if
> stdout is not a TTY, except with --both.
> * Added Gem.find_files, allows a gem to discover features provided by  
> other
> gems.
> * Added pre/post (un)install hooks for packagers of RubyGems.  (Not  
> for gems
> themselves).
> * RubyGems now installs into ~/.gem if GEM_HOME is not writable.  Use
> --no-user-install command-line switch to disable this behavior.
> * Fetching specs for update now uses If-Modified-Since requests.

May I ask that you please use XDG standard.

T.


More information about the Rubygems-developers mailing list