[Rubygems-developers] Pessimistic version constraints not working?

Chad Woolley thewoolleyman at gmail.com
Fri Oct 24 01:53:52 EDT 2008


On Thu, Oct 23, 2008 at 2:14 PM, Chad Woolley <thewoolleyman at gmail.com>wrote:

> On Thu, Oct 23, 2008 at 12:18 PM, Luis Lavena <luislavena at gmail.com>wrote:
>
>>
>> I couldn't get it working from the command line, but it works
>> perfectly using gem method.
>>
>
> Hmm, I tried from the API and it still didn't work.  It may have been using
> the "list" command via the API rather than "gem", though.  Busy now, but
> I'll look into it later...
>
>
Yeah, it works for the 'install' command, but not for 'list':

>> require 'rubygems/gem_runner';Gem::GemRunner.new.run(['install',
'activesupport','--version','>2.0.0'])
Successfully installed activesupport-2.1.2
1 gem installed


>> require 'rubygems/gem_runner';Gem::GemRunner.new.run(['install',
'activesupport','--version','~>2.0.0'])
Successfully installed activesupport-2.0.5
1 gem installed

>> require 'rubygems/gem_runner';Gem::GemRunner.new.run(['list',
'activesupport','--version','~>2.0.0'])

*** LOCAL GEMS ***

activesupport (2.1.2, 2.1.1, 2.1.0, 2.0.5, 2.0.2, 1.99.0, 1.4.4, 1.4.2)
=> nil
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rubygems-developers/attachments/20081023/3cc038f0/attachment-0001.html>


More information about the Rubygems-developers mailing list