[Rubygems-developers] Pessimistic version constraints not working?

Luis Lavena luislavena at gmail.com
Thu Oct 23 15:18:06 EDT 2008


On Thu, Oct 23, 2008 at 3:42 PM, Chad Woolley <thewoolleyman at gmail.com> wrote:
> I'm confused.  I read these:
>
> http://www.rubygems.org/read/chapter/16#page74
> http://blog.zenspider.com/2008/10/rubygems-howto-preventing-cata.html
>
> But when I try this on the command line, I still always get all local gems
> with this name returned.  Am I using it wrong, or what?
>
> $ gem list rails
> rails (2.1.1, 2.1.0, 2.0.2, 1.99.0, 1.2.6, 1.2.3)
>
> $ gem list rails --version '~>2.0.0'
> rails (2.1.1, 2.1.0, 2.0.2, 1.99.0, 1.2.6, 1.2.3)
>
> $ gem list rails --version '~>1.0'
> rails (2.1.1, 2.1.0, 2.0.2, 1.99.0, 1.2.6, 1.2.3)
>
>

I couldn't get it working from the command line, but it works
perfectly using gem method.


Luis at KEORE (D:\Users\Luis\projects\area17\a17_redux\a17_redux.git)
$ gem list rails

*** LOCAL GEMS ***

rails (2.1.1, 2.0.5, 1.2.6)

Luis at KEORE (D:\Users\Luis\projects\area17\a17_redux\a17_redux.git)
$ irb
irb(main):001:0> require 'rubygems'
=> true
irb(main):002:0> gem "rails", "~> 2.0.0"
=> true
irb(main):003:0> pp $LOAD_PATH
["D:/Users/Luis/ruby/ruby-186-p114-MINGW-rubygems-130/lib/ruby/gems/1.8/gems/rake-0.8.3/bin",
 "D:/Users/Luis/ruby/ruby-186-p114-MINGW-rubygems-130/lib/ruby/gems/1.8/gems/rake-0.8.3/lib",
 "D:/Users/Luis/ruby/ruby-186-p114-MINGW-rubygems-130/lib/ruby/gems/1.8/gems/activesupport-2.0.5/bin",
 "D:/Users/Luis/ruby/ruby-186-p114-MINGW-rubygems-130/lib/ruby/gems/1.8/gems/activesupport-2.0.5/lib"
... ]

-- 
Luis Lavena
AREA 17
-
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams


More information about the Rubygems-developers mailing list