[Rubygems-developers] Pessimistic version constraints not working?

Chad Woolley thewoolleyman at gmail.com
Thu Oct 23 14:42:38 EDT 2008


I'm confused.  I read these:

http://www.rubygems.org/read/chapter/16#page74
http://blog.zenspider.com/2008/10/rubygems-howto-preventing-cata.html

But when I try this on the command line, I still always get all local gems
with this name returned.  Am I using it wrong, or what?

$ gem list rails
rails (2.1.1, 2.1.0, 2.0.2, 1.99.0, 1.2.6, 1.2.3)

$ gem list rails --version '~>2.0.0'
rails (2.1.1, 2.1.0, 2.0.2, 1.99.0, 1.2.6, 1.2.3)

$ gem list rails --version '~>1.0'
rails (2.1.1, 2.1.0, 2.0.2, 1.99.0, 1.2.6, 1.2.3)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rubygems-developers/attachments/20081023/ecd8b0c0/attachment.html>


More information about the Rubygems-developers mailing list