[Rubygems-developers] Please test for a 1.3.1

Luis Lavena luislavena at gmail.com
Tue Oct 21 11:58:41 EDT 2008


On Tue, Oct 21, 2008 at 12:53 PM, Berger, Daniel
<Daniel.Berger at qwest.com> wrote:
>  > -----Original Message-----
>> From: rubygems-developers-bounces at rubyforge.org
>> [mailto:rubygems-developers-bounces at rubyforge.org] On Behalf
>> Of Eric Hodel
>> Sent: Monday, October 20, 2008 7:38 PM
>> To: rubygems-developers at rubyforge.org
>> Subject: [Rubygems-developers] Please test for a 1.3.1
>>
>> I will be including the current trunk on Thursday in Ruby for the
>> upcoming 1.9.1.  Shortly afterward I will release RubyGems 1.3.1.
>> There are only a few bug fixes:
>>
>> Silencing the PATH warning for unpack
>> Fixes for Gem.inflate, deflate, etc.
>> Switched to MiniTest for 1.9 compatibility Gem.dir reads
>
> Are you making minitest a requirement even for 1.8.x? That's how it
> seems to be now:
>
> Ruby 1.8.6-p114 (VC++ 8)
> Windows XP Pro
>

Looks like, the same here.

> C:\Documents and Settings\djberge\workspace\rubygems>rake test
> (in C:/Documents and Settings/djberge/workspace/rubygems)
> C:0:Warning: Gem::manage_gems is deprecated and will be removed on or
> after March 2009.
> Install minitest gem
> ./lib/rubygems/custom_require.rb:27:in `gem_original_require': no such
> file to load -- minitest/unit
>  (LoadError)
>        from ./lib/rubygems/custom_require.rb:27:in `require'
>        from C:/Documents and
> Settings/djberge/workspace/rubygems/test/gemutilities.rb:14
>        from ./lib/rubygems/custom_require.rb:27:in
> `gem_original_require'
>        from ./lib/rubygems/custom_require.rb:27:in `require'
>        from ./test/test_config.rb:7
>        from
> C:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake/rake_test_loader.rb:5
> :in `load'
>        from
> C:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake/rake_test_loader.rb:5
>        from
> C:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake/rake_test_loader.rb:5
> :in `each'
>        from
> C:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake/rake_test_loader.rb:5
> rake aborted!
> Command failed with status (1): [C:/ruby/bin/ruby -w -Ilib
> "C:/ruby/lib/rub...]
>
> The Warning line (and format) is strange, too.
>

The warning line is because Rake is using manage_gems in the script
which is being "required" by the rubygems stubs... latest version
(0.8.3 I think) have that fixed -- but memory is not my strong point
today.

> Regards,
>
> Dan
>

BTW: all tests passes on MinGW, and all test pases on mswin32 (VC6).

One thing I noticed is that when you install the gem in ~/.gem or any
other place outside the gems of the distribution, it fails.

I'll provide more info later today.

-- 
Luis Lavena
AREA 17
-
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams


More information about the Rubygems-developers mailing list