[Rubygems-developers] How to freeze gems that require native extension without sudo rights ?

Thibaut Barrère thibaut.barrere at gmail.com
Tue Nov 4 19:54:59 EST 2008

Hi Eric,

> The same way you install any other gem:
> $ gem install hpricot
> WARNING:  Installing to ~/.gem since /Library/Ruby/Gems/1.8 and
>          /usr/bin aren't both writable.
> WARNING:  You don't have /Users/drbrain/.gem/ruby/1.8/bin in your PATH,
>          gem executables will not run.
> Building native extensions.  This could take a while...
> Successfully installed hpricot-0.6.164
> 1 gem installed
> [...]

ok just got it. It works with 1.3.0 but not but 1.1.1:

gem install hpricot-0.6.164.gem
ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions into the /usr/local/lib/ruby/gems/1.8

I guess I'll just wait for the shared upgrade to rubygems 1.3.0, or use

Thanks for the feedback guys,

-- Thibaut
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rubygems-developers/attachments/20081105/9acbbc10/attachment.html>

More information about the Rubygems-developers mailing list