[Rubygems-developers] A couple patches to help JRuby

Eric Hodel drbrain at segment7.net
Tue May 27 14:59:30 EDT 2008


On May 26, 2008, at 19:48 PM, Charles Oliver Nutter wrote:

> FYI, there's a couple bugs with patches that hopefully can get into  
> the next maintenance release. We've modified them locally, but we'd  
> like to avoid the juggling act we have to do when upgrading:
>
> [#19866] Rubygems fails with NameError: StringIO
> http://rubyforge.org/tracker/index.php?func=detail&aid=19866&group_id=126&atid=575
>
> [#20379] RubyGems only looks at platform for win_platform? method,  
> and so doesn't install .bat files under JRuby
> http://rubyforge.org/tracker/index.php?func=detail&aid=20379&group_id=126&atid=575
>
> Any objections to including in the next maintenance release?

None.  I've marked them as high priority so I shouldn't forget.


More information about the Rubygems-developers mailing list