[Rubygems-developers] dependent gems not installed when using a --source gem repository

Eric Hodel drbrain at segment7.net
Thu May 15 03:37:12 EDT 2008


On May 12, 2008, at 10:04 AM, Stephen Bannasch wrote:
> I've got an alpha gem I am working on called make_models and I'm  
> hosting it now on my own gem repository. Both main and arrayfields  
> are gem dependencies of make_models.  If I download it and install  
> from a file the dependencies are resolved.
>
> I got this report from someone else who tried to install it from my  
> gem repository without having the prerequisite gems:
>
>> sudo gem install make_models --source=http://rails.dev.concord.org/gems/
>>
>> I get this error:
>>
>> (9:27:59) [tikal:/web/rails] pburney% sudo gem install make_models  
>> --source=http://rails.dev.concord.org/gems/
>> Password:
>> Bulk updating Gem source index for: <http://rails.dev.concord.org/gems/ 
>> >http://rails.dev.concord.org/gems/
>> ERROR:  Error installing make_models:
>>      make_models requires main (>= 2.8.0)
>
> Has anybody else seen this problem?

There is no main gem in that gem repository.  Either add main to that  
repository, or include both that repository and your repository as  
sources.


More information about the Rubygems-developers mailing list