[Rubygems-developers] 1.1.0 upgrade failure on Windows

Daniel Berger djberg96 at gmail.com
Sat Mar 29 08:33:01 EDT 2008


On Sat, Mar 29, 2008 at 6:25 AM, Luis Lavena <luislavena at gmail.com> wrote:
>
> On Sat, Mar 29, 2008 at 9:14 AM, Daniel Berger <djberg96 at gmail.com> wrote:
>  > Ruby 1.8.6
>  >  Windows XP
>  >
>  >  C:\Documents and Settings\djberge>gem update --system
>  >  JRuby limited openssl loaded. gem install jruby-openssl for full support.
>  >  http://wiki.jruby.org/wiki/JRuby_Builtin_OpenSSL
>  >  Updating RubyGems...
>  >  Attempting remote update of rubygems-update
>  >  Successfully installed rubygems-update-1.1.0
>  >  1 gem installed
>  >  Updating version of RubyGems to 1.1.0
>  >  Installing RubyGems 1.1.0
>  >  'RUBYOPT' is not recognized as an internal or external command,
>  >  operable program or batch file.
>  >
>  >  C:\Documents and Settings\djberge>gem -v
>  >  1.0.1
>  >
>  >  RUBYOPT is an environment variable, yes? What's it trying to run?
>  >
>  >  Regards,
>  >
>
>  I didn't get the output you got:
>
>  ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
>
>  D:\Users\Luis>set RUBYOPT=rubygems
>
>  D:\Users\Luis>gem -v
>  1.0.1
>
>  D:\Users\Luis>gem update --system --no-ri --no-rdoc
>  Updating RubyGems...
>  Updating metadata for 75 gems from http://gems.rubyforge.org
>  ...........................................................................
>  complete
>
> Attempting remote update of rubygems-update
>  Successfully installed rubygems-update-1.1.0
>  1 gem installed
>  Updating version of RubyGems to 1.1.0
>  Installing RubyGems 1.1.0
>  (zillions of install lines here)
>
>  Removing old RubyGems RDoc and ri
>  As of RubyGems 0.8.0, library stubs are no longer needed.
>  Searching $LOAD_PATH for stubs to optionally delete (may take a while)
>  ...done.
>  No library stubs found.
>
>  ------------------------------------------------------------------------------
>
>  Oh-no! Unable to find release notes in:
>         doc/release_notes/rel_1_1_0.rdoc
>
>  ------------------------------------------------------------------------------
>
>  RubyGems installed the following executables:
>         C:/Ruby/bin/gem
>
>  If `gem` was installed by a previous RubyGems installation, you may need
>  to remove it by hand.
>
>  RubyGems system software updated
>
>  D:\Users\Luis>gem -v
>  1.1.0
>
>  ===
>
>  It sounds like you're running Jruby version of gem instead of what you
>  states, Ruby 1.8.6
>  I don't have jRuby version at hand to test it. Sorry

<snip>

Oh, wow, you're right. That's weird, because it's not first in my
PATH. When I did an explicit "C:\ruby\bin\gem update --system" then it
worked fine.

I must have messed up my environment somehow. Sorry for the noise.

Regards,

Dan


More information about the Rubygems-developers mailing list