[Rubygems-developers] invalid Gem::Specification format?

Eric Hodel drbrain at segment7.net
Wed Jun 25 17:40:53 EDT 2008


On Jun 24, 2008, at 23:14 PM, Ryan Davis wrote:
> On Jun 24, 2008, at 21:26 , Chad Woolley wrote:
>> On Tue, Jun 24, 2008 at 4:08 PM, Ryan Davis <ryand- 
>> ruby at zenspider.com> wrote:
>>> you and I are already caught up, but for the record: 0.4.3 was  
>>> fixed but
>>> 0.4.2 still has the same problem. 0.4.2 was deleted but that doesn't
>>> replicate so it should be rereleased as well (unless we can find  
>>> tom online)
>>
>> OK, I just re-released from my 0.4.2 tag, packaged with RubyGems  
>> 1.2.0 release.
>>
>> I still am not sure how to reproduce this error, can you confirm or
>> tell me how to check?
>
> gah... lame. I have no idea what's wrong now:
>
> [...]
> Nothing to update

Separate bug in the update command.  The workaround is to `gem install  
rubygems-update -v 1.1.1` before `gem update --system`.


More information about the Rubygems-developers mailing list