[Rubygems-developers] invalid Gem::Specification format

Ryan Davis ryand-ruby at zenspider.com
Tue Jun 24 19:07:06 EDT 2008


On Jun 24, 2008, at 13:41 , Chad Woolley wrote:

> On Tue, Jun 24, 2008 at 9:53 AM, Jeremy d  
> <jeremydeininger at gmail.com> wrote:
>> Exception `TypeError' at
>> /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:271 - invalid
>> Gem::Specification format ["1.1.1", 3, "geminstaller", #<Gem::Version
>> "0.4.2">, Thu Jun 19 03:00:00 -0400 2008, "Automated Gem  
>> installation,
>
> Hi,
>
> This was apparently because I built the GemInstaller 0.4.2 gem with a
> pre-1.2.0 release of RubyGems.
>
> I have since re-released GemInstaller 0.4.3 built with RubyGems 1.2.0
> official, and deleted the 0.4.2 release off of RubyForge.  I hope this
> fixes everything!

deletions don't replicate, unfortunately... it'd be quicker and easier  
(until we get ahold of tom) to push another 0.4.2. Sucks... I've been  
bitten by this before too. 


More information about the Rubygems-developers mailing list