[Rubygems-developers] invalid Gem::Specification format?

Eric Hodel drbrain at segment7.net
Sun Jun 22 20:26:11 EDT 2008


On Jun 22, 2008, at 14:49 PM, Chad Woolley wrote:
> I don't have time to look into this myself, but I thought I'd mention
> it, since it sounds strange and may be some sort of regression.
>
> I released a gem (GemInstaller 0.4.2) a couple days before RubyGems
> 1.2.0, but I used Hoe 1.6.0 with the trunk version of RubyGems
> installed.
>
> Then, I got this report [1] of a stacktrace containing GemInstaller
> from someone who didn't even have GemInstaller installed.  Was this an
> issue with RubyForge, RubyGems, or my GemInstaller 0.4.2 gem
> packaging?
>
> I also saw this Pastie [2], which may be related???
>
> [1] http://thewoolleyweb.lighthouseapp.com/projects/11580/tickets/12-gem-update-blows-up
> [2] http://pastie.org/pastes/219563

You'll need to repackage your gem with 1.2.0, 1.1.1 isn't able to load  
gems from "the future" so I rolled back the specification version  
since it wasn't really important enough to bump.


More information about the Rubygems-developers mailing list