[Rubygems-developers] trunk bug: incompatible marshall file format when --list --details

Eric Hodel drbrain at segment7.net
Tue Jun 10 14:26:01 EDT 2008


On Jun 9, 2008, at 22:42 PM, Chad Woolley wrote:

> When I pass the --details option to --list --remote, I get this error:
>
> ERROR:  While executing gem ... (TypeError)
>    incompatible marshal file format (can't be read)
> 	format version 4.8 required; 45.45 given
>
> Let me know if you need more details to reproduce.

I cannot reproduce.  Looks like something got confused and you  
downloaded a yaml file instead.

$ ruby -e 'p 45.chr; Marshal.load "--"'
"-"
-e:1:in `load': incompatible marshal file format (can't be read)  
(TypeError)
	format version 4.8 required; 45.45 given	from -e:1

I see:

$ svnversion
1761M [minor change]
$ ruby -Ilib bin/gem sources -c
*** Removed specs cache ***
*** Removed user source cache ***
*** Removed latest user source cache ***
*** Removed system source cache ***
*** Removed latest system source cache ***
$ ruby -Ilib bin/gem list -r -d rails -V

*** REMOTE GEMS ***

GET 200 OK: http://gems.rubyforge.org/latest_specs.4.8.gz
GET 200 OK: http://gems.rubyforge.org/quick/Marshal.4.8/rails-2.1.0.gemspec.rz
[...]
rails (2.1.0)
     Author: David Heinemeier Hansson
     Rubyforge: http://rubyforge.org/projects/rails
     Homepage: http://www.rubyonrails.org

     Web-application framework with template engine, control-flow layer,
     and ORM.

[...]
$



More information about the Rubygems-developers mailing list