[Rubygems-developers] How to install rubygems on MinGW?

Luis Lavena luislavena at gmail.com
Fri Jun 6 08:32:52 EDT 2008

On Fri, Jun 6, 2008 at 8:05 AM, Atsushi SAKAI <sakaia at jp.fujitsu.com> wrote:
> Hi, Luis
> Thank your for quick response.
> I am trying to install rubygems running MSYS console (rxvt).
> Ruby version is ruby 1.8.4 (2005-12-24) [i386-minw32]
> Now I am using Windows XP.
> and MinGW is (from gcc) gcc.exe (GCC) 3.4.5 (mingw special)
> I do someting wrong?

Actually is hard to track, from the backtrace references looks like
you're trying to install rubygems into msys setup, and I suppose
that's maybe you installed ruby (mingw build) in there too.

Are you using Rubygems 1.1.1 package from the rubyforge page [1] or
using the svn version?

Also, from where did you get the 1.8.4 version of Ruby you're using?
are you sure is mingw32 and not cygwin? 1.8.4 sounds familiar to me
for my cygwin battle days, but can be wrong (which usually happens).

Can you provide me with the list of steps you did until you got this
issue? (installed mingw, msys, ruby, etc, and where you pick those
files) so I can pinpoint where and what is the real problem.

Luis Lavena
Human beings, who are almost unique in having the ability to learn from
the experience of others, are also remarkable for their apparent
disinclination to do so.
Douglas Adams

More information about the Rubygems-developers mailing list