[Rubygems-developers] HEADSUP RubyGems 1.2 Real Soon Now

Jeremy Kemper jeremy at bitsweat.net
Wed Jun 4 12:59:18 EDT 2008

On Wed, Jun 4, 2008 at 12:33 AM, Stephen Bannasch
<stephen.bannasch at deanbrook.org> wrote:
> At 6:22 PM -0700 6/3/08, Jeremy Kemper wrote:
>>On Tue, Jun 3, 2008 at 4:36 PM, Eric Hodel <drbrain at segment7.net> wrote:
>>> I believe RubyGems is currently feature-complete for the next release.  For
>>> the next while I'll be focusing on bugfixes and patches from the tracker.  I
>>> expect to release a new version in two weeks at minimum, possibly longer.
>>I'd love to see little-known --format-executable enabled by default
>>for gem installs.
>>This gives you bin stubs that match your ruby name, e.g. rake-1.9 for
>>ruby-1.9 and rake for ruby. Currently, both are installed as rake so
>>the latest install clobbers the previous one. This is confusing and
>>aggravating but few are aware that --format-executable solves it.
>>Changing the default would be a welcome improvement in gem install
>>experience for those working with multiple rubies and doesn't change
>>behavior for the 95% who aren't. Plus, the 1.2 release is an
>>auspicious opportunity to flip the switch just as 1.8.7 is out and
>>1.9.1 nears release.
> I would like the opposite to be the default.
> I keep all my different ruby installations separate -- I have different lib, bin, and gem repo paths for 1.8.6, 1.9. rbx, and jruby. I don't see how a single gem repository can work when gems that require native code and connections to ruby VM libraries are combined.

Unless I'm missing something, your setup is unaffected by this option
because you don't use the program prefix or suffix.


More information about the Rubygems-developers mailing list