[Rubygems-developers] Help with Gem Dependencies

Gordon Thiesfeld gthiesfeld at gmail.com
Wed Jun 4 00:29:40 EDT 2008

On Tue, Jun 3, 2008 at 10:34 PM, Bret Pettichord <bret at pettichord.com> wrote:
> I confirmed that your suggestion works as you describe. Thanks.
> However, what i want to do is make "gem install watir" work as a
> one-step install. With your suggestion it is now a 2-step install.
> ("gem update --system; gem install watir")

It may seem like I'm quibbling over semantics here, but I think at
distinction needs to be made.  Installing watir in this way is not a 2
step install, but a one step install with an added requirement.  Users
are already required to run Windows, and to have ruby installed.  This
would just require they upgrade to a newer version of RubyGems.  I
agree this isn't the most optimal solution, but it's what is available
right now. When the next version of the One Click installer ships, it
will ship with the latest production version of RubyGems, and you'll
be back to the 2 original requirements.

> Another option would be for us to move to Ruby 1.8.7. which surely has
> other benefits as well.

I would recommend against that at this point.  From what I've read,
Ruby 1.8.7 is not completely backward compatible, and code will break.
 Also, I'd be interested to hear what sort of bugs you're encountering
in 1.8.6.  Send an email to the rubyinstaller (One Click Installer
project for Windows) mailing list.



More information about the Rubygems-developers mailing list